9to5 | Action Alert: Protect low-income and vulnerable people!
1164
post-template-default,single,single-post,postid-1164,single-format-standard,ajax_fade,page_not_loaded,,qode_grid_1300,qode-child-theme-ver-1.0.0,qode-theme-ver-16.6,qode-theme-bridge,wpb-js-composer js-comp-ver-5.5.1,vc_responsive

Action Alert: Protect low-income and vulnerable people!

Action Alert: Protect low-income and vulnerable people!

Protect low-income and vulnerable people! Under the Budget Control Act, automatic cuts scheduled for January 2013 will include SNAP/food stamps, unemployment benefits, Medicaid and Medicare. These cuts will make things worse, not better. People will be hurt; more jobs will be lost.

There is a better way. Click here to tell your Senators that working people need support, not cuts to help our economy grow.